fuzz fix?

Hal Murray hmurray at megapathdsl.net
Thu Dec 5 14:33:55 UTC 2019

[Both my DSL line and land line were out for the long weekend.  I think I'm 
caught up.]

Last night Richard Laager sent me some IRC stuff indicating that the fuzz mess 
was due to NTS threads calling get_systime() which isn't thread safe.  In 
hindsight, I should have seen that sooner.

I just pushed a fix.  Please test.

Thanks to all who helped track it down and thanks to Richard for pointing out 
the problem.


I also pushed some other fixes that I worked on over the weekend.

There is now a message that gets added to your log file if there were errors 
parsing ntp.conf.
  ntpd[5469]: INIT: saw 1 parsing errors
That covers the problem where the parsing errors go to syslog but you are 
looking in ntpd.log.  (Guess how much time I spent figuring out that I had 
typed "ntp" where I needed "nts".)

The version and command line messages are now repeated after switching to a 
log file.  The idea is to get (almost) everything into ntpd.log  There are 
still some messages that go to syslog because some code is initialized (or 
whatever) before the config file is parsed.  I haven't tried to track them 

buildprep now installs certificate packages on NetBSD and FreeBSD.

I cleaned up some of the NTS logging.  (mostly getting rid of magic constants)


I'm working on some fixes to the retry time for DNS lookup.

These are my opinions.  I hate spam.

More information about the devel mailing list