Something is buggy with maxpoll...

Gary E. Miller gem at
Tue Apr 25 06:26:09 UTC 2017

Yo Achim!

On Tue, 25 Apr 2017 07:52:50 +0200
Achim Gratz <Stromeko at> wrote:

> Gary E. Miller writes:
> > Unable to duplicate.  Here is what I did:
> >
> > 1. server has a peer, minpoll=maxpoll=3  
> I've not explicitly set minpoll.

Probalby unrelated.

> > 2. server has today's git head.  
> I've just put the newest version on all four boxen.  I should perhaps
> mention that the problem has started occuring once I've started
> monitoring all other machines on the network (plus a handful of
> stratum-1 from outside) from each of these.  They are all connected to
> the same switch (I've tried to connect one of these directly to my
> router to see if it makes a difference and it did not).  This
> behaviour makes it very difficult to restart the ntpd on any of
> these, since I will often have to restart the ntpd on another one and
> then go back and see if the others are still working correctly.

Gonna be hard to debug unless you can narrow down to something we
can replicate.

> > 8. poll as shown in ntpmon and ntpq staed always at 32.  
> The displayed poll value never changes.  But the actual poll interval
> obviously gets much longer than what was set.

How can you tell?  I watched with ntpmon and the actual poll matched the
poll shown.

> I've seen over 50
> minutes without a poll (and the reach flags stay at their prvious
> value instead of shifting out every 16 seconds as they should).

Odd, I have never seen this.  And I tried several time today to see it.

Do you think the issue is in ntpmon or in ntpd?

> This
> smells like an unitialised variable somewhere that then picks up a
> random value…

Could be, but we have gcc, and pyflakes, set to detext unintialized
variables.  So cn't be a trivail issue.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
	gem at  Tel:+1 541 382 8588

	    Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the devel mailing list