Anybody object to requiring OpenSSL 1.0.2 or newer?
hmurray at megapathdsl.net
Mon Dec 9 10:54:25 UTC 2019
Anybody running on a system with really really old version of OpenSSL?
The spec requires ALPN. OpenSSL added support for ALPN in release 1.0.2
I'd like to require 1.0.2 or newer but don't want to yank the rug out from
underneath anybody. Is anybody running in an environment with an older
version? If so, what distro/version?
I don't think we have a formal support policy. I've been trying to support
(most of) the versions of distros that are supported by their providers. Many
distros support current and previous. Some have LTS (Long Term Support) for
another version or two.
Anybody running on macOS? Solaris? (Open)SUSE? ....
Fedora supports 30 and 31. Both have 1.1.1d
Debian 9/stretch is using 1.1.0l, 10/buster is on 1.1.1d
Debian 8/jessie is on LTS until June 2020. It's using 1.01.
I assume Ubuntu has something similar.
CentOS supports 6, 7, and 8.
6 has 1.0.1e-fips Support for 6 times out in another year.
I think 7 ships with 1.0.2
8 ships with 1.0.2k
NetBSD supports 7 and 8.
NetBSD 7.2 ships with 1.0.1u but 1.0.2 is available via a package and that
gets dragged in by python which is needed to build ntpsec. NetBSD 8 ships
with 1.0.2. They are working on 9.
FreeBSD supports 11 and 12.
11 has 1.0.2 12 has 1.1.1d
These are my opinions. I hate spam.
More information about the devel