type tangle in tests/ntpd/leapsec.c, Issue #479

Hal Murray hmurray at megapathdsl.net
Wed May 2 19:06:20 UTC 2018

Fedora 28 is out.  It's using gcc 8 which has tightened some type checking.  
Things like this will become much more common.

../../tests/ntpd/leapsec.c:434:19: warning: cast between incompatible 
function types from ‘int (*)(FILE * restrict,  const char * restrict,  
...)’ {aka ‘int (*)(struct _IO_FILE * restrict,  const char * restrict,  
...)’} to ‘void (*)(void *, const char *, ...)’ [-Wcast-function-type]

There are 2 other instances of the same problem.

I tried a bit to tweak the types but didn't get anywhere.  Are any type 
wizards willing to take a look at this?  Part of the tangle is that the 
prototype in the header file doesn't actually match the description in the 
man page.  It has a few restricts.

Plan B is to interject a wrapper.  I haven't tried that yet.

This is part of issue #479
A few other easy fixes are already in.

These are my opinions.  I hate spam.

More information about the devel mailing list