NTPsec on OpenSwitch

Srivatsan, Srinivasan srinivasan.srivatsan at hpe.com
Tue Jan 12 22:40:01 UTC 2016


Responses inline. When are we looking to support cross compiling ? 

On 1/12/16, 2:07 PM, "Hal Murray" <hmurray at megapathdsl.net> wrote:

>verm at darkbeer.org said:
>> Oh, it's a cross compile?  Yes, that is not supported at the moment.  Though
>> the  error shouldn't be 'No such file or directory'. 
>My cross-compile idea could well be a wild goose chase.
>Srinivasan: Can you please try running the file by hand, both when cd-ed to 
>the local directory and when using the full long name.  If it works, waf has 
>troubles running the file rather than building it.

[srinsriv] I ran it both ways and it still shows “No such file or directory”. But If I ran it as /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 OR put my ubuntu vm’s ld-linux-x86-64.so.2 in the path then it seems to work. Which means its unable to find the library its looking for when its xcompiling.

>Are there any non-execute permissions along the directory chain?
[srinsriv] Permissions are fine for the executable. More info at http://pastebin.com/raw/AJBMpqsb
$ ls -lrt
total 24
-rw-r--r-- 1 srinsriv srinsriv 6272 Jan 5 13:12 test.c.1.o
-rwxr-xr-x 1 srinsriv srinsriv 13032 Jan 5 13:12 testprog

Can you try this version of waf to see if anything changes?
[srinsriv] This version does not work either. Why do you think that the waf version would help us resolve this issue ?. Logs stored at http://pastebin.com/raw/ULRP3Vg9


More information about the devel mailing list