lfpinit() signed or unsigned?

Hal Murray hmurray at megapathdsl.net
Fri Mar 10 07:02:42 UTC 2017


esr at thyrsus.com said:
>> How about something like l_fp_time (unsigned) and
>> l_fp_delta or _fp_offset (signed)?
> More detail, please? 

Replace
  typedef uint64_t l_fp;
with
  typedef uint64_t l_fp_time;
  typedef int64_t l_fp_offset;

Then replace all the places that used to use l_fp with the correct one.

Then iterate on making macros and removing casts in the main code.


-- 
These are my opinions.  I hate spam.





More information about the devel mailing list