Python search path?? How do I test ntpq?

Hal Murray hmurray at
Mon Dec 18 00:52:14 UTC 2017

I tried to test the latest fix to ntpq.  It crashed with the same error 
because it was using the installed libraries rather than the new libraries I 
was trying to test.

I cd-ed to the build directory. ($build/main/ntpclients)
./ntpq -np mon
  File "/home/murray/ntpsec/play/hgm/main/ntpclients/ntp/", line 1076, 
in summary
    if "." not in dstadr_refid and ":" not in dstadr_refid:

[murray at hgm ntpclients]$ ll -l ntp
lrwxrwxrwx 1 murray murray 8 Dec 17 15:00 ntp -> ../pylib
[murray at hgm ntpclients]$ 

Do I have to do something else to use the new libraries?  I thought . was 
magically on the search path.

sys.path says:
['', '/usr/lib/', '/usr/lib64/python2.7', 
'/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', 
'/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', 
'/usr/lib64/python2.7/site-packages', '/usr/local/lib64/python2.7/site-package
s', '/usr/local/lib/python2.7/site-packages', '/usr/lib/python2.7/site-package

Is '' the same as '.'?

These are my opinions.  I hate spam.

More information about the devel mailing list