version stuff, autorevision

Hal Murray hmurray at
Wed Dec 13 02:04:59 UTC 2017

Something broke in my setup and I can't figure out what's going on.

I build/test on one system, then scp to other systems so I can build and test 
there.  The scp step skips .git to reduce clutter and save network time.  
Some of the other systems don't even have git installed.

I have a kludge in the script to make wafhelpers/.autorevision-cache.  It 
does get scp-ed around.

That used to work.

Now, I'm getting:
  error: No repo or cache detected.

Building with -v says:

[85/85] Processing /home/murray/ntpsec/foo/build/main/pylib/,/home/m
urray/ntpsec/foo/wafhelpers/.autorevision-cache: VERSION 
wafhelpers/ -> build/main/pylib/ 
17:50:04 runner ' VCS_EXTRA=`cat /home/murray/ntpsec/foo/VERSION` 
../wafhelpers/ -o /home/murray/ntpsec/foo/wafhelpers/.autorevis
ion-cache -e VERSION -t python >/home/murray/ntpsec/foo/build/main/pylib/versi '
error: No repo or cache detected.

Waf: Leaving directory `/home/murray/ntpsec/foo/build/main'
Build failed
 -> task in '/home/murray/ntpsec/foo/build/main/pylib/,/home/murray/
ntpsec/foo/wafhelpers/.autorevision-cache' failed with exit status 1:
        {task 139901747736240: /home/murray/ntpsec/foo/build/main/pylib/versio,/home/murray/ntpsec/foo/wafhelpers/.autorevision-cache 
VERSION, ->,.autorevision-cache}
' VCS_EXTRA=`cat /home/murray/ntpsec/foo/VERSION` ../wafhelpers/autorevision.s
h -o /home/murray/ntpsec/foo/wafhelpers/.autorevision-cache -e VERSION -t 
python >/home/murray/ntpsec/foo/build/main/pylib/ '

It did work earlier:
[2/3] Processing /home/murray/ntpsec/foo/ntpd/version.h,/home/murray/ntpsec/fo
o/wafhelpers/.autorevision-cache: VERSION wafhelpers/ -> 
ntpd/version.h wafhelpers/.autorevision-cache
17:58:27 ^[[35mrunner^[[0m ' VCS_EXTRA=`cat /home/murray/ntpsec/foo/VERSION` 
wafhelpers/ -o /home/murray/ntpsec/foo/wafhelpers/.autorevision
-cache -e VERSION -t h >/home/murray/ntpsec/foo/ntpd/version.h '
[3/3] Compiling build/host/ntpd/

I think the problem is that somebody is deleting wafhelpers/.autorevision-cach
e so it is trying to use info from  .git to recreate it and .git doesn't 

Does anybody recognize what's going on and/or have suggestions to fix it?  
Anybody remember changing anything in this area recently?

I'm not sure when the last time it worked.  I haven't tried bisecting yet, 
but that's next on my list.

These are my opinions.  I hate spam.

More information about the devel mailing list