ntp.conf new refclock configuration syntax

Achim Gratz Stromeko at nexgo.de
Sat Nov 26 13:19:16 UTC 2016

I've switched to the new refclock configuration syntax, but it seems
there is either a bug somewhere in the implementation or some mismatch
to the documentation.

I was trying to set up my NavSpark GPS to use $GPZDA and 115200 baud
like this:

refclock nmea unit 1 refid NavS mode 8 baud 115200 flag1 1

but that actually configured the serial for 0 baud and the GPS stopped
sending data.  Manually setting it back to the correct baud rate with
stty recovered operation.  Since the old syntax still seemed to work
correctly I've tried to pull the baud configuration into the mode
parameter again and that actually worked:

refclock nmea unit 1 refid NavS mode 88 flag1 1

The documentation exmaple at the end of the page also looks wrong:

refclock nmea mode baud 19200   # All sentences from /dev/gps0 at 19200 baud

It looks like the mode parameter is missing here (it might actually
interpret a missing mode as zero, but that should be commented).  It
would also be good to show the unit syntax in one of the examples for
each refclock I'd think.

It would be a good thing if there was a way to read in any old
configuration file and spit it out again in the new syntax.  Any default
values should be present as a comment so it's easy to find out what else
might need changing.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Blofeld:

More information about the devel mailing list