My first positive structural change to NTP

Achim Gratz Stromeko at
Sun Jun 26 09:22:51 UTC 2016

Eric S. Raymond writes:
> Here's how I think it should look:
> ----------------------------------------------------------------------
> refclock shm unit 0 refid GPS
> refclock shm unit 1 prefer refid PPS
> ----------------------------------------------------------------------

I think that's still perpetuating a mistake.  This whole business of
having to specify two servers (or refclocks) for the same thing should
go away.  In fact, some of the PARSE drivers already get it right and
use (default) device names for this association if you use their PPS
enabled modes.  This could be done across the board, so that the prefer
keyword isn't needed anymore just to associate the PPS source with a
refclock.  It's easy enough these days to tell udev what each device
should be named, so in principle there wouldn't even be a need to use
anything but the default names.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptation for Waldorf Blofeld V1.15B11:

More information about the devel mailing list