Fedora kernels missing hardpps

Hal Murray hmurray at megapathdsl.net
Mon Jun 20 09:34:32 UTC 2016

Mumble.  Long story.

There are two parts of PPS processing in the kernel.  One is RFC 2783 which 
describes an API for capturing the time when a pulse happens.  The other is 
RFC 1589 which describes a PLL which basically moves all the timekeeping work 
into the kernel.   If you turn on flag3 with the PPS driver, it tries to 
activate the kernel PLL.

I hadn't tried the kernel PLL for a while, maybe because I turned it off ages 
ago when the Linux PPS area was being rewritten.  So I tried it.  It gives a 
not-implemented error.  But I thought the code was there.

Poking around, that chunk of code in the kernel depends upon NTP_PPS which 

config NTP_PPS
        bool "PPS kernel consumer support"
        depends on !NO_HZ
          This option adds support for direct in-kernel time
          synchronization using an external PPS signal.

          It doesn't work on tickless systems at the moment.

The kernels shipped with Fedora, Debian, and Ubuntu all have NO_HZ turned on.

I haven't found the config file for any of the ARM kernels.  One try got the 
same result.

I guess I'll try building a kernel and/or running on FreeBSD or NetBSD.

These are my opinions.  I hate spam.

More information about the devel mailing list